flex兼容性

写在前面

flex布局早在2009年就有了,使用最新的flex语法会发现支持程度并不好,即使是在“高端”浏览器上也是如此,比如Chrome、Firefox、Safari、Android、IOS Safari下支持程度各不相同

网上现有的代码中充斥着各种版本,在Chrome下运行一般都没有问题,Firefox一般也还好,但Android与IOS Safari下就显得非常无力了。之所以会出现这样的局面,主要是历史原因,从2009年到2015年,期间W3C规范有了多次更新,浏览器支持程度也就有了差异

一.W3C各个版本的flex

2009 version

标志:display: box; or a property that is box-{*} (eg. box-pack)

2011 version

标志:display: flexbox; or the flex() function or flex-pack property

2012 version

标志:display: flex/inline-flex; and flex-{*} properties

2014 version

新增了对flex项z-index的规定

2015 W3C Editor’s Draft

没有大的改动

P.S.注意2015的是W3C Editor’s Draft,只是个草案,还处于修修改改的阶段,还没有征集浏览器供应商的意见

二.浏览器兼容性

关于flex的W3C规范:http://dev.w3.org/csswg/css-flexbox-1/

浏览器兼容性可以参考CanIUse:http://caniuse.com/#feat=flexbox

根据CanIUse的数据可以总结如下:

IE10部分支持2012,需要-ms-前缀

Android4.1/4.2-4.3部分支持2009,需要-webkit-前缀

Safari7/7.1/8部分支持2012,需要-webkit-前缀

IOS Safari7.0-7.1/8.1-8.3部分支持2012,需要-webkit-前缀

所以需要考虑新版本2012:http://www.w3.org/TR/2012/CR-css3-flexbox-20120918/

而Android需要考虑旧版本2009:http://www.w3.org/TR/2009/WD-css3-flexbox-20090723/

三.浏览器兼容的flex语法

上面分析得很清楚,针对需要兼容的目标使用对应版本的语法就好了,下面给出常用的布局代码:

为了更好的兼容性,我们需要给容器声明flex-h/flex-v,而不是一般的flex:

所以,建议在需要兼容Android时(2009版语法)采用flex-h/flex-v声明容器使用flex模式,在不需要兼容Android时(2012版语法)使用flex设置容器

注意:上面给的代码并不是完全兼容各个高端浏览器的,但要比任何其它现有代码兼容性好,具体兼容性测试结果请看Demo

四.flex布局Demo

在线测试:Demo

测试结果:

Android4.2.2不支持换行

Android4.2.2下伪元素位置表现不一致

IOS Safari 7.1的表现与Chrome28、Chrome43、Firefox的表现一致

更多测试结果请反馈给我,谢谢

注意 :从测试结果可以发现flex布局会把伪元素当作元素来分配空间(文档好像有提到给伪元素设置position: fixed/absolute;可以避免这一情况,本文暂未验证),但我们一般希望伪元素只有装饰作用,不影响布局,这与我们的预期不一致。所以, 当flex布局中有伪元素时要特别小心,尽可能多地进行浏览器兼容性测试,或者改用float布局

发表评论